View Issue Details

IDProjectCategoryView StatusLast Update
0000850Populous: The BeginningScriptingpublic2021-07-14 07:40
ReporterDivinityAssigned ToKosjak 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000850: Having FLYBY_SET_EVENT_ZOOM speeds up and ruins beta flybys
DescriptionUsing the popscript command FLYBY_SET_EVENT_ZOOM speeds up the flyby on the beta version of the game.
It speeds the flyby even if this command hasn't been called yet.
Steps To ReproduceUse a FLYBY_SET_EVENT_ZOOM inside a flyby, and see how commands such as FLYBY_SET_EVENT_ANGLE or FLYBY_SET_EVENT_POS stop working properly (being sped up)
Even if the zoom command hasn't been called yet, all the flyby will be affected from start.
TagsNo tags attached.
Build Number3520

Activities

Divinity

2020-12-01 02:05

reporter   ~0000388

test the beginning levels in SP (flyby will be very fast)

i realized the problem might not be due to the zoom command (idk how to edit the ticket).
the problem seems to be related to whether you start the level using the solar system, or using the level selector (speeds up if using level selector. but upon restart the level, speed is normal again)

Kosjak

2020-12-01 07:13

administrator   ~0000389

Very noticeable in level 9 right at start, restarting will give a different flyby speed. Issue most likely related to the fact you start in world view with first launch of level which causes conflict with flyby event.

Divinity

2020-12-01 09:36

reporter   ~0000390

i saved middle flyby (it was sped up), and when loaded it was even more sped up
also later load games made flyby disappear

Issue History

Date Modified Username Field Change
2020-12-01 01:11 Divinity New Issue
2020-12-01 02:05 Divinity Note Added: 0000388
2020-12-01 07:13 Kosjak Note Added: 0000389
2020-12-01 09:36 Divinity Note Added: 0000390
2021-05-21 14:33 Kosjak Sticky Issue No => Yes
2021-07-14 07:40 Kosjak Assigned To => Kosjak
2021-07-14 07:40 Kosjak Status new => resolved
2021-07-14 07:40 Kosjak Resolution open => fixed
2021-07-14 07:40 Kosjak Sticky Issue Yes => No