View Issue Details

IDProjectCategoryView StatusLast Update
0000133Populous: The Beginning[All Projects] Generalpublic2016-03-24 20:56
ReporterBrandanAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000133: Increase max objects limit
DescriptionAlso increase max buildings, people sometimes hit it during long PP games (lots and lots of towers, including convering BD etc)

pop3.h
#define MAX_NUM_THINGS 2000 // - make it a multiple of 10
#define MAX_BUILDING_LIMIT (80)
TagsNo tags attached.
Build Number

Relationships

related to 0000152 closedBrandan Spells casts are dropping at a higher fequency. 

Activities

David

2015-07-31 06:28

reporter   ~0000036

Increased max things from 2000 to 20000 (10x), max buildings from 80 to 160 (2x), added new #define so that the game still loads only 2000 things from levels (thus retaining the same format and compatibility):

#define MAX_NUM_LEVEL_THINGS 2000

Brandan

2015-08-03 17:40

administrator   ~0000037

This has been updated to 8000 objects from 20,000 objects due to issues with the draw system failing around 10,000 objects.

Brandan

2015-08-12 16:47

administrator   ~0000062

This change may be causing spells to be dropped without being cast even more.

Issue History

Date Modified Username Field Change
2015-07-28 19:53 David New Issue
2015-07-31 06:22 David Assigned To => David
2015-07-31 06:22 David Status new => assigned
2015-07-31 06:28 David Note Added: 0000036
2015-07-31 06:28 David Status assigned => resolved
2015-07-31 06:28 David Resolution open => fixed
2015-08-03 17:39 Brandan Fixed in Version => 1.1
2015-08-03 17:40 Brandan Note Added: 0000037
2015-08-12 16:45 Brandan Relationship added related to 0000152
2015-08-12 16:47 Brandan Note Added: 0000062
2016-03-24 20:56 Brandan Reporter David => Brandan
2016-03-24 20:56 Brandan Assigned To David =>