View Issue Details

IDProjectCategoryView StatusLast Update
0001098Populous: The BeginningMultiplayerpublic2021-03-26 09:48
ReporterRalicarneAssigned To 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5 
Target VersionFixed in Version 
Summary0001098: Placing plans down in Multiplayer with Fog of War on makes the game run out of sync
DescriptionWhenever someone places down a plan in multiplayer with fog of war on the game desyncs. It doesn't seem to happen on each plan, but if you place plans down fast enough it will crash due to unrecoverable out of sync.
Steps To Reproduce1. Host a game with multiple players and turn on Fog of War.
2. Place down a hut or tower plan.
3. Desync and eventually crash :(
TagsNo tags attached.
Build Number3678

Activities

Ralicarne

2021-03-25 03:12

developer   ~0000425

Something I found out: it resyncs when you place a plan in an area that is fogged for the other player(s). If you place a tower plan in a location that is revealed to all it does work without resyncing.

Issue History

Date Modified Username Field Change
2021-03-21 13:52 Ralicarne New Issue
2021-03-25 03:12 Ralicarne Note Added: 0000425
2021-03-26 09:48 Kosjak Status new => resolved
2021-03-26 09:48 Kosjak Resolution open => fixed