View Issue Details

IDProjectCategoryView StatusLast Update
0000596PopRE Matchmaker[All Projects] Generalpublic2020-01-10 16:24
ReporterBrandanAssigned ToBrandan 
PriorityimmediateSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000596: Lobby connection issues
DescriptionSometimes when playing with 8 players someone cannot chat or will have a negative ping.
TagsNo tags attached.

Activities

Brandan

2019-11-28 19:09

administrator   ~0000274

This is an issue with how the matchmaker relays packets. This is not reproducible in any lan environment or direct ip with Gabber.

Brandan

2019-11-28 19:13

administrator   ~0000275

Other information about this is sometimes players can chat and ready but they cannot send or receive chat packets. This is not an issue with the network code of the game.

Brandan

2019-11-28 19:21

administrator   ~0000277

Last edited: 2019-11-28 19:24

View 2 revisions

They'll get in a match like below but have 1 ping (-1 in memory and has no last contact heart beats) they cannot chat, they cannot click ready or change teams but can read chat

https://www.twitch.tv/videos/512204295?t=11h39m33s
https://www.twitch.tv/videos/512204295?t=03h43m05s

Brandan

2019-11-28 19:28

administrator   ~0000278

Last edited: 2019-11-28 19:30

View 2 revisions

Here is it happening to the streamer
https://www.twitch.tv/videos/512204295?t=03h17m00s

He cannot send or receive any chat packets.

Kosjak

2019-11-29 01:59

administrator   ~0000280

Cannot reproduce the issue via direct-ip (outside mm)

Brandan

2019-12-02 19:04

administrator   ~0000293

Possibly related to the "You cannot kill the supervisor" fatal error message which causes other players to drop packets (?)

Brandan

2019-12-02 19:13

administrator   ~0000294

The longer you stay in the lobby the more likely this issue is to occur. This issue will occur 100% of the time depending how long you sit in the lobby.

Brandan

2019-12-02 21:57

administrator   ~0000295

Possibly fixed in eb6e3593d1e8fda9fce360cad6c4c828140d4a8a

Brandan

2019-12-28 17:35

administrator   ~0000303

This issue was reproducible using the matchmaker in 1.03.

Brandan

2019-12-28 17:38

administrator   ~0000304

Last edited: 2019-12-28 17:39

View 3 revisions

d4d4 typed !sendlog after it occurred. This occurred 3 times in a row for him.

d4d4> so basically
d4d4> i could ally
d4d4> but not click in

12/28/2019 18:39 MDT

Brandan

2020-01-10 16:24

administrator   ~0000311

Doesn't seem to be an issue anymore.

Issue History

Date Modified Username Field Change
2019-11-28 17:51 Brandan New Issue
2019-11-28 19:08 Brandan Assigned To => IncaWarrior
2019-11-28 19:08 Brandan Status new => assigned
2019-11-28 19:09 Brandan Note Added: 0000274
2019-11-28 19:09 Brandan Priority normal => immediate
2019-11-28 19:09 Brandan Severity minor => major
2019-11-28 19:09 Brandan Reproducibility have not tried => sometimes
2019-11-28 19:10 Brandan Sticky Issue No => Yes
2019-11-28 19:10 Brandan Project Populous: The Beginning => PopRE Matchmaker
2019-11-28 19:10 Brandan Category Multiplayer => General
2019-11-28 19:13 Brandan Note Added: 0000275
2019-11-28 19:21 Brandan Note Added: 0000277
2019-11-28 19:24 Brandan Note Edited: 0000277 View Revisions
2019-11-28 19:28 Brandan Note Added: 0000278
2019-11-28 19:30 Brandan Note Edited: 0000278 View Revisions
2019-11-29 01:59 Kosjak Note Added: 0000280
2019-12-02 19:04 Brandan Note Added: 0000293
2019-12-02 19:13 Brandan Project PopRE Matchmaker => Populous: The Beginning
2019-12-02 19:13 Brandan Severity major => block
2019-12-02 19:13 Brandan Reproducibility sometimes => always
2019-12-02 19:13 Brandan Note Added: 0000294
2019-12-02 19:13 Brandan Assigned To IncaWarrior => Brandan
2019-12-02 21:57 Brandan Note Added: 0000295
2019-12-28 17:35 Brandan Note Added: 0000303
2019-12-28 17:35 Brandan Project Populous: The Beginning => PopRE Matchmaker
2019-12-28 17:38 Brandan Note Added: 0000304
2019-12-28 17:38 Brandan Note Edited: 0000304 View Revisions
2019-12-28 17:39 Brandan Note Edited: 0000304 View Revisions
2020-01-10 16:24 Brandan Status assigned => resolved
2020-01-10 16:24 Brandan Resolution open => fixed
2020-01-10 16:24 Brandan Note Added: 0000311