View Issue Details

IDProjectCategoryView StatusLast Update
0000144Populous: The BeginningScriptingpublic2017-11-29 16:34
ReporterKhickmanAssigned ToKhickman 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 
Target Version1.1Fixed in Version1.1 
Summary0000144: The Script Command "GIVE_UP_AND_SULK" Causes Multiplayer Resync and Always Attacks the "Current Player"
DescriptionThe GIVE_UP_AND_SULK script command in Populous, which tells an enemy to "give up" by sending all of their remaining followers to the player's base is flawed in that it always targets the current player's tribe. For single player, this is always the blue tribe, but if you manipulate the game to allow for scripts in multiplayer, then it will point to the game's player's tribe (e.g. for the blue player, they will attack blue, for red they will attack red, etc.) causing a resynchronization.

Moreover, if the blue tribe is allied to the player who gives up, they will then be attacked by their ally, which seems to be an oversight.

Steps To ReproducePlease see the description.
Additional InformationA good way to fix this would be to instruct the player who is giving up to attack their first enemy (in order of player number). By removing the pointer reference to the "current player" and doing this check, giving up players will no longer attack their allies and the resynchronization issue will not occur in multiplayer.
TagsNo tags attached.
Build Number

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-08-04 15:38 Khickman New Issue
2015-08-04 15:38 Khickman Status new => assigned
2015-08-04 15:38 Khickman Assigned To => Khickman
2015-08-05 20:35 Brandan Status assigned => resolved
2015-08-05 20:35 Brandan Fixed in Version => 1.1
2015-08-05 20:35 Brandan Resolution open => fixed
2017-11-29 16:34 Brandan Category Scripting => Scripting1
2017-11-29 16:40 Brandan Category Scripting1 => Scripting