View Issue Details

IDProjectCategoryView StatusLast Update
0000143Populous: The BeginningMultiplayerpublic2017-11-29 16:32
ReporterKhickmanAssigned ToKhickman 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000143: Casting Lightning in Multiplayer Game while Shaman is in Prison causes Resynchronization
DescriptionCasting the lightning spell in a multiplayer game where there are shamans trapped in prisons results in the game resynchronizing. Before the resynchronization occurs, players whose shamans are free will not observe anything other than the lightning spell being case. Players who have trapped shamans will observer that their, and only their, shaman will die.
Steps To Reproduce1. Start up a multiplayer game where there are shamans in prisons. Make sure the lightning spell can be acquired for use.
2. Free one of the shamans from the prison.
3. Have the player with the freed shaman cast the lightning spell anywhere.
4. Observer that the game will resynchronize.
Additional InformationThis bug was caused by a last minute hack in which casting the lightning spell checks to see if a shaman is trapped in a prison. If the shaman is trapped and is the current player's shaman, then she will be killed of. This was done for the losing condition on level 15, Incarcerated.
TagsNo tags attached.
Build Number

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-08-04 15:29 Khickman New Issue
2015-08-04 15:29 Khickman Status new => assigned
2015-08-04 15:29 Khickman Assigned To => Khickman
2015-08-04 20:24 Khickman Status assigned => resolved
2015-08-04 20:46 Brandan Fixed in Version => 1.1
2015-08-04 20:55 Brandan Product Version 1.1 =>
2015-08-04 20:55 Brandan Target Version 1.1 =>
2015-08-04 20:56 Brandan Resolution open => fixed
2017-11-29 16:32 Brandan Category Multiplayer => Multiplayer1
2017-11-29 16:40 Brandan Category Multiplayer1 => Multiplayer